Ignoring the | character?

Share your macros, knowledge, solutions, services, ...
Post Reply
jfusco
Posts: 2
Joined: Tue Apr 11, 2017 3:49 pm

Ignoring the | character?

Post by jfusco » Fri Apr 14, 2017 6:58 pm

I tried to post this several days ago but it never appeared.

I am copying a text string that includes the pipe | character. I want to use the portion before the | as part of an email subject. For instance, if the string is "Mary had a little | lamb." I want my email subject to be "Regarding: Mary had a little." Or, if the string is "The quick brown fox jumped over|the lazy dog" I want the subject to be "Regarding: The quick brown fox jumped over." Once the subject is constructed, I'm calling a vbscript file to open a new email with that subject.

I can capture the string fine and am OK with the subject ending up being "Regarding: Mary had a little | lamb" but | is some sort of native delimiter and when PK goes to append the copied text onto the "Regarding: " string it asks me if I want the first part or the second part. No matter what I choose, my new email is never opened.

I have tried reading each word individually and stopping when I hit the pipe | but PK just glosses over it. I have tried telling PK to ignore the | but that doesn't happen either. I've even looked in the system variables for something like _vPipe but that doesn't appear to exist. If my target text were a specific length I could just grab those words but the length is variable.

I'm running version 7.6.7 because that's what the company has a license for.

Any help is appreciated.

-- Joe

Post Reply